首页 > 上海日记 > WordPress升级Simple Tagging报错
2008
12-13

WordPress升级Simple Tagging报错

  当北街正在很兴奋的体验 WordPress 2.7 带来新鲜感的时候,却不幸的发现 Simple Tagging 插件升级之后报错了。这次不仅我碰到了麻烦,其他博友也吃了更新插件亏。还好默默の丸总结了解决方法,这里给大家推广一下。

  之前的 RC 都没装,所以不知道还有这么个问题。装上以后想来很多人都会在后台看见插件提示,提示 simple-tags 不兼容,要求装 simple-tagging。我当时就没走脑子,以为作者就是没事把两个一样的插件名字换来换去对应各个版本——但实际 simple-tagging 还是那个老的插件,根本没更新过!我是逛这里看到的提示明白了怎么回事。

  解决办法很简单,使用编辑器打开 simple-tags 插件目录中的 simple-tags.php ,把 2.7 的版本号加进去,在35行:

if (
strpos($wp_version, '2.5') !== false || 
strpos($wp_version, '2.6') !== false || 
strpos($wp_version, '2.7') !== false
) {

  这样加入 WordPress 2.7版本号的判断即可。其余的完全不必搭理。

  update:simple-tags升级了。

最后编辑:
作者:北街

身高八尺,腰围也是八尺!

捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!

WordPress升级Simple Tagging报错》有 3 条评论

  1. sky 说:

    哎,确实没有更新过了的

  2. Johnny 说:

    好像这个插件昨天已经升级了,今天我在本地把blog升级到2.7没有出现什么问题

  3. neekey 说:

    没用过这个插件,好像很多人在用,我也试试

留下一个回复

你的email不会被公开。