首页 > 上海日记 > Popularity Contest插件引发致命错误
2010
02-26

Popularity Contest插件引发致命错误

  有一次北街为了做测试关闭了博客所有正在使用的插件,当我再重新启动它们的时候,发现 Popularity Contest 插件发生了错误。伴随着 WordPress 2.5 的一些更新, Popularity Contest 插件出现了一些问题,在后台激活该插件的时候,可能会出现“该插件不存在”或者“该插件会引发致命错误,无法启用”的报错。

  下面讲一下如何让“Popularity Contest”插件适用于 WordPress 2.5 或者更高版本:

  如果你是直接更新为 WordPress 2.5 或者更高版本

  打开你的 Popularity Contest 插件编辑页面,找到如下代码:

require('../../wp-blog-header.php');

  用以下代码代替:

require('../wp-blog-header.php');

  如果你是新安装的 WordPress 2.5 或者更高版本

  除了以上步骤外,你还要找到以下代码:

if (isset($_GET['activate']) && $_GET['activate'] == ‘true’) {

  用下面的代码代替:

if (isset($_GET['action']) && $_GET['action'] == ‘activate’) {

  完成上面的步骤后相信你的 Popularity Contest 插件就可以完美地工作了。

最后编辑:
作者:北街
身高八尺,腰围也是八尺!
捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!

Popularity Contest插件引发致命错误》有 23 条评论

  1. 北街 说:

    @羽中 我也喜欢升级,但是由于虚拟主机限制,wp2.9之后就无法升级了……

  2. 羽中 说:

    我是升级狂,typecho都跟着SVN build版本每周升级;)

留下一个回复

你的email不会被公开。

This site uses Akismet to reduce spam. Learn how your comment data is processed.